View unanswered posts | View active topics It is currently Sat Sep 21, 2019 2:20 pm



Reply to topic  [ 7 posts ] 
Turbo'd Slaters TA build. 
Author Message
QFP80 - Contributor
User avatar

Joined: Wed Jan 16, 2008 11:09 am
Posts: 99
Location: New Zealand
Greeting's fellow petrogeeks,

Under orders from fearless Fred I created this thread for the TA/vero build i intend to run my turbo'd EFI'd Citroen GS with

EDIT: Comments here: viewtopic.php?f=62&t=1337

Image

these are images of the car (above), and the beginnings of the TA/vero ECU (below)

Image

Indeed Fred commented that it was a long motherf****r, I could not help but blush.

the Engine is a 1299cc engine from a later model Citroen GSA with a toyota trans speed sensor replacing the original diagnostic TDC sensor and the flywheel machined with 10 more grooves in it to create a 12-1 type signal.
injectors are 300cc from a some sort of Ford mounted in the original manifold runners.
Igniton is achieved with a subrau wasted spark coil and igniter.

Up till now the car has run reliably 1st on a MS1 V3 board then downgraded to a MS1 V2.2 when I stole the V3 for my supra.
The current engine is junk as it suffers from much blow by after a heroic boost wind of 18PSI. It still runs fine but breathes heavily on anything higher than 5psi boost so it is a perfect candidate as a test mule and its simple set up makes for easy implementation of a fledgling EMS.

I must thank those involved in procuring the TA card for me and to Fred for having confidence that id actually do something with it.

let the ecu construction begin!!


Daniel.


Last edited by Fred on Thu Sep 29, 2011 12:01 pm, edited 1 time in total.

Add comments thread link.



Thu Sep 29, 2011 11:48 am
Profile
QFP80 - Contributor
User avatar

Joined: Wed Jan 16, 2008 11:09 am
Posts: 99
Location: New Zealand
"Some" progress......

Image

sure, the size of it is overkill but it makes it so easy to work on and as its a back yard build I feel
the more awkward and gangly it looks, the better.....

the H1 will have a ribbon cable connecting it to the TA cad but ill just use jumper wire on the H2 as the pin usage is minimal so a 50pin ribbon cable would just be pointless.


ok meow, its time for sleepies


Fri Oct 21, 2011 12:18 pm
Profile
QFP80 - Contributor
User avatar

Joined: Wed Jan 16, 2008 11:09 am
Posts: 99
Location: New Zealand
Im sweating like the proverbial after mucking about all day in my shed that turns into a sauna in the summer,
BUT......

my slater runs!!!
fred you bastard IT RUNS!!!!!


#edit,

vids to follow, but much to some ppl's disgust i am off to a bbq, seeing it is the summer and all you know.


Tue Jan 03, 2012 7:36 am
Profile
QFP80 - Contributor
User avatar

Joined: Wed Jan 16, 2008 11:09 am
Posts: 99
Location: New Zealand
Well after struggling with a serious lack of motivation i decided to take some pic and the TA build as it sits in my Citroen.

Image

Image

Image

Image

I need to find a housing of some description to that the wires dont get tugged upon and things cant short out the bottom of the board.
AND, finish the heat sinking of the fets and regs...

I also need to coble some sort of connection from the turbo to the throttle body where the lame water to air intercooler used to be.
then I can drive it to the classic car and hotrod show in a few weeks....
oh, and run boost...... yay!


Mon Jan 09, 2012 6:21 am
Profile
QFP80 - Contributor
User avatar

Joined: Wed Jan 16, 2008 11:09 am
Posts: 99
Location: New Zealand
well it has been a while, so I thought I'd update this thread...

this TA based ECU has now run my volvo engine and now sports 5 ign outputs and 4 injection outputs.

It's a MESS!!!!

Image

Image

Image


its hacky, its messy, its badly set out, I guess its a bit like the human brain... old shit remains with new shit as new shit is needed. actually I thnk the human brain is more hacky.

old dogs die hard and it will be running another engine soon.


Sat Jun 14, 2014 9:59 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15333
Location: Home sweet home!
em_knaps wrote:
old dogs die hard and it will be running another engine soon.

But not quite yet! Sorry about that. I'll look into fixing this for you (and a number of others) fairly soon as it's of pretty high importance and is long overdue.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Jun 15, 2014 4:19 am
Profile WWW
QFP80 - Contributor
User avatar

Joined: Wed Jan 16, 2008 11:09 am
Posts: 99
Location: New Zealand
Id like to see some of the vids from today, especially the ones where your giggling when I give you the fingers during the non starting engine...

most amusing.


Sun Jun 15, 2014 12:33 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.