DIYEFI.org Forum
http://forum.diyefi.org/

Jag for EDIS thread
http://forum.diyefi.org/viewtopic.php?f=67&t=2439
Page 1 of 1

Author:  AncientGeek [ Thu Apr 17, 2014 8:27 pm ]
Post subject:  Jag for EDIS thread

I'm looking at a 0.4 alpha build so some things may be different to the 0.6

The edis input is a 12v hall type signal.

Looking at the schematic notes :

R19 should not be used for edis but on the same schematic it says R19 should be 1K for Hall, 10k for VR.
RPM0-IN- should not be connected for edis so the way I read it it should not matter if R19 is installed or not.
But then where does the edis signal get its ground? (I'm stupid, help me here.)
The schem notes are a little contradictory saying in one place RPM0-IN- should be grounded and in an other place it should be floating (for Hall/Opto)
Also does edis need the R22 pullup resistor?

what would be the best candidate for the edis output? This is a simple square wave that controls timing but must be syncronized with the square wave input.

Author:  DeuceEFI [ Thu Apr 17, 2014 9:08 pm ]
Post subject:  Re: Jag for EDIS thread

Keep in mind I have not tested this with an actual EDIS module, my notes in the schematics were for reference only and like the Jaguar design subject to be revised as needed.

AncientGeek wrote:
R19 should not be used for edis but on the same schematic it says R19 should be 1K for Hall, 10k for VR.

EDIS PIP is a 12v digital output from the EDIS module to the ECM as a RPM input. I would use a 10k current limiting resistor for R18 and install the 1k R22 pullup resistor. If the RPM0 input proves to be troublesome and loose sync then you can replace R18 with a 1k.

AncientGeek wrote:
RPM0-IN- should not be connected for edis so the way I read it it should not matter if R19 is installed or not.

RPM0-IN- should be connected to ground and R19 and R83 (both 1k resistors) should be installed as the zero crossing reference of 2.5v

AncientGeek wrote:
But then where does the edis signal get its ground? (I'm stupid, help me here.)

You should have a ground wire that runs from your EDIS module connector to ground. It uses this as the ground reference.

AncientGeek wrote:
The schem notes are a little contradictory saying in one place RPM0-IN- should be grounded and in an other place it should be floating (for Hall/Opto)
Also does edis need the R22 pullup resistor?

See above ^ :)

Author:  Fred [ Thu Apr 17, 2014 9:12 pm ]
Post subject:  Re: Jag for EDIS thread

For the output, not sure yet, likely one of the port T channels, though.

For the input, where does it say floating? That's not good enough. I'm unsure what R19 is, but it's likely an input current limit, if so, 1k is correct. If it's the -ve input current limit then 1k is still correct, and grounding the outer end of it is correct provided that you put another 1k to 5v from the other end of that resistor such that the -ve input of the MAX chip itself has 2.5V at it.

Ground for the EDIS if it has a signal ground wire to connect is just into any "sensor ground" connection, or the "shielding wire" grounds, which are the same. This is just an inter-module reference, though, not really specifically for that signal. Hope that makes sense.

EDIT: Deuce beat me to it! Posting anyway, will read his now.

EDIT2: I disagree strongly about R18, it must be 1k to gain the performance that we demand. Otherwise fine.

Fred.

Author:  DeuceEFI [ Thu Apr 17, 2014 9:24 pm ]
Post subject:  Re: Jag for EDIS thread

Here is a link to the Jaguar 0.4-alpha schematic for easy reference.

https://github.com/DeuceEFI/Jaguar/raw/0.4-alpha/docs/Jaguar-Schematic.pdf

R19 and R83 make up the 2.5v voltage divider for digital inputs (which include Hall Effect and Opto inputs).

Author:  Fred [ Thu Apr 17, 2014 10:53 pm ]
Post subject:  Re: Jag for EDIS thread

For reference: viewtopic.php?f=67&t=2334

Image

Author:  AncientGeek [ Fri Apr 18, 2014 10:28 am ]
Post subject:  Re: Jag for EDIS thread

My comments about r19 were based on the 0.4 notes dated 16 Feb 2013. I didn't think of looking at the 0.6 schematics, duh.

I see the comment about not installing R19 and R16 has been removed in the later version.

Also it no longer says RPM-0- should be left disconnected. Makes lot more sense now.

Author:  Fred [ Fri Apr 18, 2014 10:36 am ]
Post subject:  Re: Jag for EDIS thread

Good to hear! :-)

Author:  DeuceEFI [ Tue Apr 22, 2014 5:27 am ]
Post subject:  Re: Jag for EDIS thread

DeuceEFI wrote:
EDIS PIP is a 12v digital output from the EDIS module to the ECM as a RPM input. I would use a 10k current limiting resistor for R18 and install the 1k R22 pullup resistor. If the RPM0 input proves to be troublesome and loose sync then you can replace R18 with a 1k.

I mis-spoke (mis-typed, rather) earlier about this ^

You should use a 1k resistor for R18. This is the same as what I use for my 0v/12v Cam position sensor on my Deuce and on the S10.

Only use the 10k resistor for R18 if you are using a VR input source.

Author:  AncientGeek [ Sun Jan 07, 2018 8:13 am ]
Post subject:  Re: Jag for EDIS thread

The first FreeEms advance controlled EDIS engine has finally run : viewtopic.php?f=55&t=2836#p44089

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/