View unanswered posts | View active topics It is currently Sun Dec 17, 2017 12:58 pm



Reply to topic  [ 26 posts ]  Go to page 1, 2, 3  Next
Giving Jaguar the Acid Test 
Author Message
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
As I recently described in detail, most of the Jaguar board is fairly indestructible. Or rather, it should be fairly indestructible. Such circuits are nothing without testing, though. Various aspects have been tested in isolation, however AFAIK the entire system has not been tested together. Thus I propose that Andy make an unlikely sacrifice to the gods of speed and put his completed 0.4 board to the test. What I propose is listed below in detail:

Setup

  • Robust 12V supply, IE, a battery with good charge, on charge @ 13.5 - 14.4V
  • Secondary supply of 5 - 15V completely independent so as to be able to apply negative voltages
  • Solid ground and power wiring to the battery with say a 20A fuse to prevent fire

Tests

  • 1 DPAK under short circuit conditions (0.1ohm shunt) to 12V supply directly (or through the 20A fuse) traces should not burn, record hold current
  • 1 SOT223, same as above.
  • 1 DPAK under negative Voltage conditions, observe any/all behaviour(s).
  • 1 SOT223, same as above.
  • Use bench test to put each FET under thermal load with 80% duty and 5A load, realistically you can expect all 8 DPAKs to carry as much as 2.5A each worst case, perhaps heat test in parallel and ensure board survives extended length test?
  • Each protected analogue input individually connected to 12V supply and then negative supply with Voltage @ MCU and Voltage @ rail measured and verified as OK in each case.
  • Progressively connect all protected analogue inputs to 12V supply and measure supply rail after each addition. Also monitor heat in clamp circuit, and if possible, even if through modification, monitor current through clamp circuit too (insert a shunt resistor of 0.1ohm?) until finally having all analogue inputs shorted to 12V without a blown supply or MCU. (hopefully)
  • Force a potential of 12+ Volts (use 110V AC mains if you're brave, should be fine, layout/isolation dependent) between the comms ground and circuit ground and ensure comms are reliable (power board with 9V battery or other convenient isolated source) and ensure laptop is unplugged and running independently too.
  • Overload 5V output to level necessary to trip fuse and record what that is. I don't recall which fuse you used, but if it's got too high of a trip current, the regulator could bail first, if so, we need to revise the fusing or regulator.
  • Short ignition drives to ground with 12V out and 12V with ground out and ensure both IC and resistor do not overheat.
  • Scraping bottom of barrel now, but perhaps try to induce instability in each power supply by externally switching a 500mA load at a moderate frequency? Observe stability of both supplies CPU behaviour?

If you're not comfortable with anything, please just say so. Maybe I can find some time to do it here. Most of the above is designed to be OK, so it should all be non destructive.

If you can get good quality footage of any of the tests with a commentary that'd be cool too, but not necessary.

Any other ideas welcome too. Huff may have some acid for us.

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Fri Jul 26, 2013 1:51 pm
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Thu Feb 25, 2010 3:57 am
Posts: 563
Location: Gosport, IN USA
Fred wrote:
[*]1 DPAK under short circuit conditions (0.1ohm shunt) to 12V supply directly (or through the 20A fuse) traces should not burn, record hold current

For these tests the input was tied to +5v simulating 100% duty cycle.
Connected DPAK output directly to +13.8v battery, the VND7N04 DPAK instantly went into thermal shutdown, the trace between the DPAK and the output terminal was unharmed as was the ground trace to the DPAK.

Before testing the Ford style starter solenoid as the load, I verified that the Ford style starter solenoid drew a steady 3.6A when energized directly from the battery through my DMM setup to measure current.
I connected a Ford style starter solenoid to the output terminal and recorded a current of 3.6A with the DPAK warm to the touch. I left it connected this way for 60 seconds and noticed no change in behavior.

Before testing the GM low-Z injector as the load, I verified that it drew a steady 7.3A after an inrush current of 9.5A when energized directly from the battery through my DMM setup to measure current.
I connected the GM low-Z injector to the output terminal and recorded 6.9A before the injector started pulsing on/off after about 10 seconds of being on (which didn't occur connected directly to the battery). I also noticed the DPAK was VERY warm to the touch. This verified that the VND7N04 was protecting itself as designed.

Fred wrote:
[*]1 SOT223, same as above.

Same results as the DPAK version.

That is all for now, I'll work on the other tests after dinner.

Andy.

_________________
Andy.
FreeEMS vehicle #11, 1932 Ford 5 Window Coupe with a 1996 GM 3.1L SFI V6 with DIS ignition
FreeEMS vehicle #16, 1996 Chevrolet S10 2.2L SFI I4 with DIS ignition
http://www.coolefi.com


Sat Aug 17, 2013 10:39 pm
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Thu Feb 25, 2010 3:57 am
Posts: 563
Location: Gosport, IN USA
Results of today's testing of the Jaguar 0.4-alpha board:

Fred wrote:
[*]Each protected analogue input individually connected to 12V supply and then negative supply with Voltage @ MCU and Voltage @ rail measured and verified as OK in each case.


For these tests I read 4.99v on the output of the 5v-analog power supply:

Applied +13.8v to TPS input, 5v-analog rail read 4.99v, MCU input read 1.19v.
Applied +13.8v to MAP input, 5v-analog rail read 4.99v, MCU input read 1.20v.
Applied +13.8v to CHT input, 5v-analog rail read 4.99v, MCU input read 1.18v.
Applied +13.8v to IAT input, 5v-analog rail read 4.99v, MCU input read 1.18v.
Applied +13.8v to O2 input, 5v-analog rail read 4.99v, MCU input read 1.20v.

Applied -13.8v to TPS input, 5v-analog rail read 4.99v, MCU input read -0.28v.
Applied -13.8v to MAP input, 5v-analog rail read 4.99v, MCU input read -0.28v.
Applied -13.8v to CHT input, 5v-analog rail read 4.99v, MCU input read -0.28v.
Applied -13.8v to IAT input, 5v-analog rail read 4.99v, MCU input read -0.28v.
Applied -13.8v to O2 input, 5v-analog rail read 4.99v, MCU input read -0.28v.

NOTE: I did not build the MAT(SPR1) or the MAF circuits but they should give similar results as the circuits are similar.


Fred wrote:
[*]Progressively connect all protected analogue inputs to 12V supply and measure supply rail after each addition. Also monitor heat in clamp circuit, and if possible, even if through modification, monitor current through clamp circuit too (insert a shunt resistor of 0.1ohm?) until finally having all analogue inputs shorted to 12V without a blown supply or MCU. (hopefully)


I connected +13.8v to the TPS, MAP, CHT, IAT and the O2 inputs, the 5v-analog rail read 4.99v. The current limiting resistors on each of the inputs dropped the extra input voltage so the 5v-analog rail did not increase in voltage.

Fred wrote:
[*]Overload 5V output to level necessary to trip fuse and record what that is. I don't recall which fuse you used, but if it's got too high of a trip current, the regulator could bail first, if so, we need to revise the fusing or regulator.


The regulator shutdown before I was able to trip the 0.5A fuse, so I will need to find a lower rated fuse.

_________________
Andy.
FreeEMS vehicle #11, 1932 Ford 5 Window Coupe with a 1996 GM 3.1L SFI V6 with DIS ignition
FreeEMS vehicle #16, 1996 Chevrolet S10 2.2L SFI I4 with DIS ignition
http://www.coolefi.com


Mon Aug 26, 2013 2:47 am
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
Thanks for working on this, Andy! :-)

DeuceEFI wrote:
Applied +13.8v to TPS input, 5v-analog rail read 4.99v, MCU input read 1.19v.
Applied +13.8v to MAP input, 5v-analog rail read 4.99v, MCU input read 1.20v.
Applied +13.8v to CHT input, 5v-analog rail read 4.99v, MCU input read 1.18v.
Applied +13.8v to IAT input, 5v-analog rail read 4.99v, MCU input read 1.18v.
Applied +13.8v to O2 input, 5v-analog rail read 4.99v, MCU input read 1.20v.

Really weird, but I think I figured out what it was when chatting to you. I'll let you explain though :-)

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Mon Aug 26, 2013 12:48 pm
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Thu Feb 25, 2010 3:57 am
Posts: 563
Location: Gosport, IN USA
Since I had the over-voltage circuit trace/pad errors as described in http://forum.diyefi.org/viewtopic.php?f=67&t=2253 which burned the VRH input to the microcontroller (and possibly holding the MCU input pins low once I cut the VRH pin off the MCU) these results may not be entirely accurate. I will remove the dead MCU and repeat the tests then I will replace the MCU and repeat the tests.

_________________
Andy.
FreeEMS vehicle #11, 1932 Ford 5 Window Coupe with a 1996 GM 3.1L SFI V6 with DIS ignition
FreeEMS vehicle #16, 1996 Chevrolet S10 2.2L SFI I4 with DIS ignition
http://www.coolefi.com


Mon Aug 26, 2013 1:52 pm
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
Thanks Andy, you're a '*'!

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Mon Aug 26, 2013 2:34 pm
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Thu Feb 25, 2010 3:57 am
Posts: 563
Location: Gosport, IN USA
With the dead MCU removed, here are the new readings:

Applied +13.8v to TPS input, 5v-analog rail read 4.99v, MCU input read 5.25v.
Applied +13.8v to MAP input, 5v-analog rail read 4.99v, MCU input read 5.25v.
Applied +13.8v to CHT input, 5v-analog rail read 4.99v, MCU input read 5.25v.
Applied +13.8v to IAT input, 5v-analog rail read 4.99v, MCU input read 5.25v.
Applied +13.8v to O2 input, 5v-analog rail read 4.99v, MCU input read 5.25v.

_________________
Andy.
FreeEMS vehicle #11, 1932 Ford 5 Window Coupe with a 1996 GM 3.1L SFI V6 with DIS ignition
FreeEMS vehicle #16, 1996 Chevrolet S10 2.2L SFI I4 with DIS ignition
http://www.coolefi.com


Mon Aug 26, 2013 5:51 pm
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
That's more like it! :-)

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Mon Aug 26, 2013 6:32 pm
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Tue Mar 02, 2010 2:33 pm
Posts: 1201
Location: Australia
Sweet! :-)


Thu Aug 29, 2013 1:01 am
Profile
DIP8 - Involved

Joined: Fri Aug 16, 2013 6:59 am
Posts: 21
What about ESD test?


Fri Aug 30, 2013 10:43 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 26 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.