DIYEFI.org Forum
http://forum.diyefi.org/

Ayuda con firmware
http://forum.diyefi.org/viewtopic.php?f=61&t=2671
Page 4 of 5

Author:  ToxicGumbo [ Mon Jun 27, 2016 3:03 am ]
Post subject:  Re: Ayuda con firmware

Someone correct me if I'm wrong, but doesn't the only FreeEMS compatible version of EMStudio require Qt4?


-Jeff

Author:  Fred [ Mon Jun 27, 2016 3:56 am ]
Post subject:  Re: Ayuda con firmware

ToxicGumbo wrote:
Someone correct me if I'm wrong, but doesn't the only FreeEMS compatible version of EMStudio require Qt4?

You're not wrong, tu eres correcto! :-D

Aldo, you're getting the tuning software from the wrong place with the wrong instructions. Sorry about that. It's abandonware, really. The one I gently maintain a little is here and here:

https://github.com/fredcooke/emstudio and https://github.com/fredcooke/emstune-freeems

Clone with 'git clone https://github.com/fredcooke/emstudio.git'

Then follow the instructions: https://github.com/fredcooke/emstudio/b ... /README.md

"sudo apt-get install build-essential libqt4-dev libqt4-opengl-dev libqt4-opengl-dev qt4-qmake libqwt-dev libqt4-declarative libqjson-dev freeglut3-dev pkg-config"

cd emstudio

git clone https://github.com/fredcooke/emstune-freeems.git plugins/freeems

qmake -r

make

cd core

./emstudio

Then you should be in luck. Not sure what half of those Debian Spanish messages mean, but you may have to clean up some of what you did by removing things (without removing stuff that was already there and is needed).

Perdoneme para Ingles!

Fredito.

Author:  AldoQ [ Tue Jun 28, 2016 4:43 am ]
Post subject:  Re: Ayuda con firmware

OK
Now i have the tunning software installed :o
tanks Fred
but.. i think i need to find how to install the ftdi driver, because i plug the usb cable the 2 led of the ftdi blinks but the ems studio cant connect

Author:  Fred [ Tue Jun 28, 2016 4:55 am ]
Post subject:  Re: Ayuda con firmware

ftdi driver is built in, are you in dialout group? A snippet from the code of one of my apps:

"Please add your user to the 'dialout' group by replacing <username>"
"sudo adduser <username> dialout"

After this you have to fully log out of the UI and log back in so that the group applies to your user in the terminal you launch it from.

Or you could reboot, if you prefer.

Check groups with, surprise, 'groups':

Code:
fred@falcon:~$ groups
fred lp dialout cdrom floppy sudo audio dip video plugdev netdev scanner bluetooth systemd-network


Check device with:

ls -al /dev/ttyUSB*

before and after plugging it to see it show up :-)

Getting close! :-D

Author:  AldoQ [ Tue Jun 28, 2016 4:58 am ]
Post subject:  Re: Ayuda con firmware

lsusb shows
Bus 002 Device 018: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

Author:  Fred [ Tue Jun 28, 2016 4:59 am ]
Post subject:  Re: Ayuda con firmware

One thing, have you loaded some firmware to it for EMStudio to talk to? If not, you'll need to do that. My suggestion, go and get FUCT! :-) If getting FUCT is too hard, let me know and I'll furnish you with UL :-)

Author:  AldoQ [ Wed Jun 29, 2016 1:51 am ]
Post subject:  Re: Ayuda con firmware

hi
./build.py install_dependencies

Cleaning up...
------------------------------------------------------------
BUILD FAILED - Unable to install batch dependencies.
------------------------------------------------------------
Build finished at 2016-06-28 19:48:06
Build took 5 seconds (5396 ms)

:?:

Author:  Fred [ Wed Jun 29, 2016 4:25 am ]
Post subject:  Re: Ayuda con firmware

That command is not included in the instructions! https://github.com/MrOnion/fuct These are, though:

  1. sudo apt-get install python-pip
  2. sudo pip install --upgrade pybuilder colorlog pyserial futures
  3. pyb
  4. cd target/dist/fuct-<version>
  5. python setup.py install
  6. fuctloader -s /dev/tty.usbserial load MyFirmware.S19

Something like that! :-)

Fred.

Author:  AldoQ [ Wed Jun 29, 2016 6:48 pm ]
Post subject:  Re: Ayuda con firmware

HI
in 3 step


aldo@aspire-AO725:~$ sudo apt-get install python-pip
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
python-pip ya está en su versión más reciente.
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
thunderbird-globalmenu gir1.2-ubuntuoneui-3.0 firefox-globalmenu libubuntuoneui-3.0-1
Utilice «apt-get autoremove» para eliminarlos.
0 actualizados, 0 se instalarán, 0 para eliminar y 241 no actualizados.
aldo@aspire-AO725:~$ pip install --upgrade pybuilder colorlog pyserial futures
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/late ... ingwarning.
SNIMissingWarning
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/late ... ormwarning.
InsecurePlatformWarning
Requirement already up-to-date: pybuilder in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: colorlog in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: pyserial in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: futures in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: pip>=7.0 in /usr/local/lib/python2.7/dist-packages (from pybuilder)
Requirement already up-to-date: tblib in /usr/local/lib/python2.7/dist-packages (from pybuilder)
Requirement already up-to-date: wheel in /usr/local/lib/python2.7/dist-packages (from pybuilder)
aldo@aspire-AO725:~$ pyb
PyBuilder version 0.11.9.dev20160616212308
Build started at 2016-06-29 12:38:08
------------------------------------------------------------
------------------------------------------------------------
BUILD FAILED - Project directory does not contain descriptor file: /home/aldo/build.py
------------------------------------------------------------
Build finished at 2016-06-29 12:38:08
Build took 0 seconds (1 ms)
aldo@aspire-AO725:~$

Author:  AldoQ [ Wed Jun 29, 2016 7:00 pm ]
Post subject:  Re: Ayuda con firmware

[ERROR] Test has error: plugins.python.distutils_plugin_tests.InstallDependenciesTest.test_should_return_single_dependency_string_with_version
Traceback (most recent call last):
File "/home/aspire/pybuilder/src/unittest/python/plugins/python/distutils_plugin_tests.py", line 97, in test_should_return_single_dependency_string_with_version
self.project.depends_on("spam", "0.7")
File "/usr/local/lib/python2.7/dist-packages/pybuilder/core.py", line 407, in depends_on
self._install_dependencies.add(Dependency(name, version, url))
File "/usr/local/lib/python2.7/dist-packages/pybuilder/core.py", line 236, in __init__
version = ">=" + str(Version(version))
File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/packaging/version.py", line 210, in __init__
match.group("pre_n"),
TypeError: 'NoneType' object is not callable

------------------------------------------------------------
BUILD FAILED - There were 15 error(s) and 0 failure(s) in unit tests
------------------------------------------------------------

Page 4 of 5 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/