View unanswered posts | View active topics It is currently Tue Dec 18, 2018 12:14 pm



Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Ayuda con firmware 
Author Message
QFP80 - Contributor

Joined: Fri Apr 04, 2008 1:26 am
Posts: 31
hi

i have some trouble


aspire@aspire-AO725:~/usbdm$ ls
Install_USBDM Install_USBDM~ Utilities
aspire@aspire-AO725:~/usbdm$ sudo ./Install_USBDM

Copying rules file to /etc/udev/rules.d
==================================================================

Installing USBDM shared libraries to /usr/local/lib
==================================================================
rm: no se puede borrar «/usr/local/lib/libusbdm*»: No existe el archivo o el directorio
cp Utilities/libusbdm.so.4.9 /usr/lib
cp Utilities/libusbdm-debug.so.4.9 /usr/lib
cp Utilities/libusbdm-tcl.so.4.9 /usr/lib
cp Utilities/libusbdm-tcl-debug.so.4.9 /usr/lib
cp Utilities/libusbdm-arm.so.4.9 /usr/lib
cp Utilities/libusbdm-arm-debug.so.4.9 /usr/lib
cp Utilities/libusbdm-dsc.so.4.9 /usr/lib
cp Utilities/libusbdm-dsc-debug.so.4.9 /usr/lib
cp Utilities/libusbdm-wx.so.4.9 /usr/lib
/sbin/ldconfig.real: No se puede efectuar «stat» sobre /lib/i686-linux-gnu: No existe el archivo o el directorio
/sbin/ldconfig.real: No se puede efectuar «stat» sobre /usr/lib/i686-linux-gnu: No existe el archivo o el directorio
/sbin/ldconfig.real: Se ha dado la ruta «/lib/i386-linux-gnu» más de una vez
/sbin/ldconfig.real: Se ha dado la ruta «/usr/lib/i386-linux-gnu» más de una vez
/sbin/ldconfig.real: No se puede efectuar «stat» sobre /usr/lib/i386-linux-gnu/libnss_db.so: No existe el archivo o el directorio
libusbdm-wx.so.4 -> libusbdm-wx.so.4.9
libusbdm-dsc.so.4 -> libusbdm-dsc.so.4.9
libusbdm-arm-debug.so.4 -> libusbdm-arm-debug.so.4.9
libusbdm.so.4 -> libusbdm.so.4.9
libusbdm-debug.so.4 -> libusbdm-debug.so.4.9
libusbdm-arm.so.4 -> libusbdm-arm.so.4.9
libusbdm-tcl-debug.so.4 -> libusbdm-tcl-debug.so.4.9
libusbdm-tcl.so.4 -> libusbdm-tcl.so.4.9
libusbdm-dsc-debug.so.4 -> libusbdm-dsc-debug.so.4.9

USBDM Properties Directory already exists - /home/aspire/.usbdm

Copying Device Descriptions & Data
=====================================================================

Copying Device Flash Images
=====================================================================

Done


Wed Jun 08, 2016 6:42 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15204
Location: Home sweet home!
Ummm, why are you doing that instead of using the .deb package and installing with 'sudo dpkg -i usbdm<version>.deb' ? (replace usbdm<version> with whatever it's called)

Nevertheless, what you may need to do is create symlinks to those directories from whatever your equivalents are called, IF you want that script to work. I'm not sure what they're supposed to be.

Did you try the deb?

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Wed Jun 08, 2016 9:59 pm
Profile WWW
QFP80 - Contributor

Joined: Fri Apr 04, 2008 1:26 am
Posts: 31
ok

this another one

aspire@aspire-AO725:~$ ls
00.pdf Descargas exci.zip MARIANA AVITIA.odt OASIS WATEVER.odt Untitled 1.odt
01.pdf Documentos fontconfig mask.odp Plantillas Untitled 5 andrea olmeca.odt
02.pdf Escritorio freeems-loader-master meso.odp Público usbdm_4.11.1.60-1-i386.deb
Biblioteca de calibre ETIQUETAS.odp FreeEMS-SerialIO-master Música TARJETA.odt Vídeos
DELFINES.odt examples.desktop Imágenes oasis.odt Ubuntu One
aspire@aspire-AO725:~$ sudo dpkg -i usbdm_4.11.1.60-1-i386.deb
(Leyendo la base de datos ... 311107 ficheros o directorios instalados actualmente.)
Preparing to unpack usbdm_4.11.1.60-1-i386.deb ...
Unpacking usbdm (4.11-1) over (4.11-1) ...
dpkg: problemas de dependencias impiden la configuración de usbdm:
usbdm depende de libwxgtk3.0-0; sin embargo:
El paquete `libwxgtk3.0-0' no está instalado.
usbdm depende de libwxbase3.0-0; sin embargo:
El paquete `libwxbase3.0-0' no está instalado.
usbdm depende de libxerces-c3.1; sin embargo:
El paquete `libxerces-c3.1' no está instalado.
usbdm depende de libtcl8.5; sin embargo:
El paquete `libtcl8.5' no está instalado.

dpkg: error al procesar el paquete usbdm (--install):
problemas de dependencias - se deja sin configurar
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Se encontraron errores al procesar:
usbdm
aspire@aspire-AO725:~$


Thu Jun 09, 2016 3:15 am
Profile
QFP80 - Contributor

Joined: Fri Apr 04, 2008 1:26 am
Posts: 31
ok
ya instale el libwxgtk3
es posible usarlo sin el code warrior
osea con la modificacion que tu propones?
Install_USBDM_NO_CW

estube buscando y no encontre en el usbdm_4.11.1.60-1-i386.deb algun archivo que se llame install usbdm
gracias


Thu Jun 09, 2016 4:13 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15204
Location: Home sweet home!
Si, posible sin code warrior.

Para los dependencias no tienes: apt-get install -f

Dice eso en la otra pagina ;-)

Seguro que 32 bit? No 64 bit? I know 64 didn't used to work due to broken packaging, but I managed to sneak 32 bit onto my 64 bit laptop OK.

Para modificaciones, buscar con "dpkg -L usbdm" y "|grep <filename fragment>" si necesario.

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Thu Jun 09, 2016 4:22 am
Profile WWW
TO220 - Visibile

Joined: Mon May 30, 2011 5:59 am
Posts: 11
Just posting here because i have the same issue... Any chance you sorted it out?


Wed Jun 22, 2016 12:09 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15204
Location: Home sweet home!
On the same OS! :-D But Ned's a LOT closer to me than you are, so hopefully we can figure it out and tell you the solution(s). Ned's got one difference, though, his board is not yet validated to be 100% correct and happy, whereas a carefully assembled Jaguar is known to be good. This leaves me hopeful that Ned's board is now in fighting fit form and just needs some better USBDM code or some such similar thing. Fingers crossed!

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Wed Jun 22, 2016 12:47 am
Profile WWW
QFP80 - Contributor

Joined: Fri Apr 04, 2008 1:26 am
Posts: 31
HI
problem solved :lol2:
era el puto chip
im put a new 9s12 and now the firmware is loaded with the latest win usbdm
ahora necesito aprender a usar la interface para hacer el tunnig
best regards


Wed Jun 22, 2016 3:10 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15204
Location: Home sweet home!
The interface es "horible", you'll want to do that on Ubuntu for sure, and with my latest source, with fixes. It's still muy malo, though. You also need a configuration. And you'll probably want up to date source, which you need to talk to me about access to. Good work! Ned's close, too. We were talking earlier.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Wed Jun 22, 2016 8:10 am
Profile WWW
QFP80 - Contributor

Joined: Fri Apr 04, 2008 1:26 am
Posts: 31
HI
OK i have the mcu with the firmware loaded
now im try to install the tunning software emstudio
but...
i have the next error

aspire@aspire-AO725:~$ sudo apt-get install git qt5-qmake qt5-default build-essential libqt5serialport5-dev libudev-dev qtdeclarative5-dev qt-quick1-5-dev qtscript5-dev libqjson-dev freeglut3-dev
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete qt-quick1-5-dev

im try fo fix but still dont work

sudo apt-get update
sudo apt-get install qtquick1-5-dev-tools


aspire@aspire-AO725:~$ sudo apt-get install qtquick1-5-dev-tools
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
account-plugin-windows-live gwibber-service libmpdec2 libquvi-scripts
libquvi7 libupstart1 linux-image-3.13.0-34-generic
linux-image-extra-3.13.0-34-generic
Use 'apt-get autoremove' to remove them.
Se instalarán los siguientes paquetes NUEVOS:
qtquick1-5-dev-tools
0 actualizados, 1 se instalarán, 0 para eliminar y 332 no actualizados.
Necesito descargar 162 kB de archivos.
Se utilizarán 440 kB de espacio de disco adicional después de esta operación.
Des:1 http://mirror.steadfast.net/ubuntu/ trusty/universe qtquick1-5-dev-tools i386 5.2.1-1ubuntu1 [162 kB]
Descargados 162 kB en 0seg. (335 kB/s)
Seleccionando el paquete qtquick1-5-dev-tools previamente no seleccionado.
(Leyendo la base de datos ... 318238 ficheros o directorios instalados actualmente.)
Preparing to unpack .../qtquick1-5-dev-tools_5.2.1-1ubuntu1_i386.deb ...
Unpacking qtquick1-5-dev-tools (5.2.1-1ubuntu1) ...
Configurando qtquick1-5-dev-tools (5.2.1-1ubuntu1) ...
aspire@aspire-AO725:~$ sudo apt-get install git qt5-qmake qt5-default build-essential libqt5serialport5-dev libudev-dev qtdeclarative5-dev qt-quick1-5-dev qtscript5-dev libqjson-dev freeglut3-dev
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete qt-quick1-5-de


Sun Jun 26, 2016 11:29 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 48 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.