View unanswered posts | View active topics It is currently Tue Apr 25, 2017 7:43 am



Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
ruzki´s '98 Megane Coupe 2.0 16V F7R (31st) 
Author Message
QFP80 - Contributor
User avatar

Joined: Thu Jun 20, 2013 4:24 pm
Posts: 86
Quote:
EGO is WAY too rich or not calibrated at all, or not present.

I have mounted the OEM small band because i´m switching from OEM ECU to FreeEms.
I will mount the LC-1 back if the FreeEms is running good.

Georg


Mon Jul 28, 2014 5:52 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14558
Location: Home sweet home!
ruzki wrote:
why it does it shows aitor ?? :indiff:

Don't ask me! It's your log :-D If you were working closely with me, and using provided firmware s19s, it certainly wouldn't.

Quote:
sadly IAT is correct :roll: while idle it sometimes rises up to 60-65°C and while driving it drops back to 30°C at this weather conditions (25°C outside).

This sounds like an MAT sensor, NOT an IAT sensor. If you read anything more than 0.5 *C away from ambient while at WOT above 2k RPM, something is very very wrong with your car. IE, it's magical. For the time being, you must connect an IAT (not an MAT) to your IAT input. If you do not have an IAT, that sucks, but fix the car. Where is your "IAT" mounted, exactly? Post a photo?

Quote:
So that´s why i need a 3D idle valve pwm table :mrgreen:
and a idle spark advance table.

All in good time. You need to get the basics right first. VERY FAR from it at the moment. :-)

Quote:
Quote:
choose a fixed duty for the time being

what duty do you mean ?

Idle valve PWM duty cycle. Choose a value that will:

  • Not let the engine stall while cold after 10 or so seconds of manual intervention
  • Not rev excessively high once warm

Extend manual intervention to a longer period until you find a value that suits... :-p Fancy idle comes later. You have MUCH bigger problems than that. Even if YOU don't realise it.

ruzki wrote:
Quote:
EGO is WAY too rich or not calibrated at all, or not present.

I have mounted the OEM small band because i´m switching from OEM ECU to FreeEms.
I will mount the LC-1 back if the FreeEms is running good.

Ahh, OK. That makes some sense. Is this your only car or something? You're never going to satisfy me enough without putting a wideband in for your logging sessions. Your tune could be miles off and no one would know. We make hard log-backed evidence based changes here. Arbitrary because someone wants something is not good enough. Need must be demostrated with hard data.

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Mon Jul 28, 2014 11:50 pm
Profile WWW
QFP80 - Contributor
User avatar

Joined: Thu Jun 20, 2013 4:24 pm
Posts: 86
Quote:
This sounds like an MAT sensor, NOT an IAT sensor. If you read anything more than 0.5 *C away from ambient while at WOT above 2k RPM, something is very very wrong with your car. IE, it's magical. For the time being, you must connect an IAT (not an MAT) to your IAT input. If you do not have an IAT, that sucks, but fix the car. Where is your "IAT" mounted, exactly? Post a photo?

i have marked the Sensor ! for me it is a IAT because it sits between the air filter an throttle body !
Yes right at WOT the temperature drops to ambient temperature but i am not driving all the time at WOT :? LOL
If i´m driving in the city temperature easily rises to to 60°C !

Image

Quote:
Idle valve PWM duty cycle. Choose a value that will:

Not let the engine stall while cold after 10 or so seconds of manual intervention
Not rev excessively high once warm

Believe me there no such value for this engine !!!!
but i choose 39% duty @ 92Hz (M$-II values)

Quote:
You're never going to satisfy me enough without putting a wideband in for your logging sessions.

If i´m not driving with the M$-II i remove the LC-1 from the car because i don't want to wear out the LSU 4.2.
But if the car will idle without holding the throttle all the time and rpm can go higher than 3500rpm i will put the LC-1 and make a proper log ! i promise :mrgreen:

Quote:
Need must be demostrated with hard data.

If the 60-2 decoder will be able to Rev over 4000rpm and some basic idle code is implemented i will proof with hard data !

Georg


Attachments:
F7R (47).jpg
F7R (47).jpg [ 225.79 KiB | Viewed 2488 times ]
Wed Jul 30, 2014 9:23 pm
Profile
QFP80 - Contributor
User avatar

Joined: Thu Jun 20, 2013 4:24 pm
Posts: 86
update..

got the idle valve running with basic pwm warmup code.
engine is still not reving over ~2000rpm.

will add a vid the next days.

Georg


Tue Oct 21, 2014 4:12 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14558
Location: Home sweet home!
Congratulations on being the first person to actually use PWM idle! :-)

I've got three independent things in the pipeline that will help your RPM issues. Super busy at home right now, though. Doing the best that I can.

Looking forward to watching your video.

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Tue Oct 21, 2014 8:15 pm
Profile WWW
QFP80 - Contributor
User avatar

Joined: Thu Jun 20, 2013 4:24 pm
Posts: 86
yes ! Thank you !

https://www.youtube.com/watch?v=tglC2ub ... ata_player

Georg


Sat Oct 25, 2014 4:58 pm
Profile
QFP80 - Contributor
User avatar

Joined: Thu Jun 20, 2013 4:24 pm
Posts: 86
Fred, when do you want to release the code with table based idle ?
For me it is working ...

Georg


Wed Mar 11, 2015 11:31 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14558
Location: Home sweet home!
Have remained super busy with new job and new house and new car(s) and fixing the ute, etc. The code I sent you works, but not in the way we want it to, and no one could understand why so far. Typically code gets released when it works properly and is complete. That code only works in a non-proper way. Apologies for delays. i'm getting closer to my keyboard every day. Should be on the job early next week, I'd say.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Wed Mar 11, 2015 7:42 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.