View unanswered posts | View active topics It is currently Thu Sep 21, 2017 5:07 pm



Reply to topic  [ 45 posts ]  Go to page 1, 2, 3, 4, 5  Next
AiToR51's 1992 Ford Sierra XR4i 2.0 (24th) 
Author Message
QFP80 - Contributor
User avatar

Joined: Sun Aug 21, 2011 6:26 pm
Posts: 77
Location: Spain
I've work a lot of hours in this car..

As stock it had a 2.0 8v DOHC engine with 125bhp and I wanted more. So firstly I improved it a bit in NA (4-2-1 exhaust manifold and good exhaust, camshafts changed, chip in std ECU...), but I wanted more again. So installed a turbo with a MS1 to control it. And now that will change to a FreeEMS :P (ASAP)


Image

Image

Engine:
Image


ECU (DIY build):

Image

Image


a lot of wires. Too much I think. I've to solve that.



ignitors far from ECU (3 BIP373, only 2 used at this time)

Image



this place will be remembered as my first FreeEMS run place:

Image

first run video:
http://www.youtube.com/watch?v=uVUZ2oag52Q


PS: currently in building. I will upgrade this with more info soon.

_________________
Sierra XR4i 2.0T


Sat Oct 19, 2013 8:00 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14771
Location: Home sweet home!
Car sounds super sweet, dude! Nice work :-)

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Oct 20, 2013 5:10 am
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Tue Mar 02, 2010 2:33 pm
Posts: 1201
Location: Australia
Great stuff!


Sun Oct 20, 2013 10:59 pm
Profile
QFP80 - Contributor
User avatar

Joined: Sun Aug 21, 2011 6:26 pm
Posts: 77
Location: Spain
Here is my first config ( https://github.com/AiToR51/freeems-vanilla/tree/OMG.GZ ). I hope I've pushed it ok as I'm not very used to use git.


I've lost first run log :( :shock: :oops:

Tomorrow I will post EMStudio screen shots of the Tables I've used

_________________
Sierra XR4i 2.0T


Sun Oct 20, 2013 11:10 pm
Profile
LQFP112 - Up with the play

Joined: Tue May 01, 2012 4:17 pm
Posts: 211
Location: Shrewsbury PA
AiToR51 wrote:
I've lost first run log :( :shock: :oops:


How? EMStudio issue or what?

AiToR51 wrote:
Tomorrow I will post EMStudio screen shots of the Tables I've used


Fwiw you can export the tables via the "Export" button on both 2D and 3D tables, or select everything and copy/paste as a CSV into either a text editor, or into a spreadsheet application as alternatives to having to use screenshots.

_________________
EMStudio
Interesting Stuff
My Car


Sun Oct 20, 2013 11:35 pm
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14771
Location: Home sweet home!
Looks to be pushed OK. There is a problem with your commit, though: https://github.com/AiToR51/freeems-vani ... 0d917bbeab

+#elif CONFIG == PETERTRUCK_ID
+#include "../data/thermistors/Denso-2k2Bias.h"

copy paste fail on the ID ;-)

Nicely done, otherwise.

That ford sensor, got any ID info for it, photos of it, documentation for it, etc? The copyright in that new file should be either 2008 - 2013 or just 2013 as it's new. Currently says 2011.

Your ID is 24, not 17, btw ;-) And I have a commit that cleans that up that I'll likely split out of Jeff's config (rather than waiting for him to get more done) and push up soonish. Perhaps tomorrow.

Along with screenies of your three primary tables, please also dump each table out (export as mike posted while I was writing this) as json and dump the entire config using emstudio. attach here.

Mike, no, not your fault :-)

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Oct 20, 2013 11:37 pm
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14771
Location: Home sweet home!
PS, push new commits to fix that stuff so I don't have to review ALL of it again ;-) Once I'm happy I can squash it down into a single commit and pull it in. Then you can get your firmware from the build server ready to go with updated code ;-)

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Oct 20, 2013 11:39 pm
Profile WWW
QFP80 - Contributor
User avatar

Joined: Sun Aug 21, 2011 6:26 pm
Posts: 77
Location: Spain
malcom2073 wrote:
AiToR51 wrote:
I've lost first run log :( :shock: :oops:


How? EMStudio issue or what?

AiToR51 wrote:
Tomorrow I will post EMStudio screen shots of the Tables I've used


Fwiw you can export the tables via the "Export" button on both 2D and 3D tables, or select everything and copy/paste as a CSV into either a text editor, or into a spreadsheet application as alternatives to having to use screenshots.


It was my fault. I overwrited it when compressing some files.

Yes, I exported the tables when configured them to have a backup and no lose data between firmware updates. I said screen shot because Fred told me that :P

Fred wrote:
Looks to be pushed OK. There is a problem with your commit, though: https://github.com/AiToR51/freeems-vani ... 0d917bbeab

+#elif CONFIG == PETERTRUCK_ID
+#include "../data/thermistors/Denso-2k2Bias.h"

copy paste fail on the ID ;-)

Nicely done, otherwise.

That ford sensor, got any ID info for it, photos of it, documentation for it, etc? The copyright in that new file should be either 2008 - 2013 or just 2013 as it's new. Currently says 2011.

Your ID is 24, not 17, btw ;-) And I have a commit that cleans that up that I'll likely split out of Jeff's config (rather than waiting for him to get more done) and push up soonish. Perhaps tomorrow.

Along with screenies of your three primary tables, please also dump each table out (export as mike posted while I was writing this) as json and dump the entire config using emstudio. attach here.

Mike, no, not your fault :-)

Fred.


Yes, you are right on the ID number, I used some "random" because I didn't know which one could be mine :lol2:


LOL on "PETERTRUCK_ID" copy fail, that's the reason I was getting near perfect readings of IAT but with a few degrees out :lol2: :lol2: :lol2: thanks.

This afternoon when coming house I will attach all the files and temp sensor info. Here I don't have any of that.

Fred wrote:
PS, push new commits to fix that stuff so I don't have to review ALL of it again ;-) Once I'm happy I can squash it down into a single commit and pull it in. Then you can get your firmware from the build server ready to go with updated code ;-)


ok, good. I will fix that.

_________________
Sierra XR4i 2.0T


Mon Oct 21, 2013 7:32 am
Profile
LQFP112 - Up with the play
User avatar

Joined: Tue Jan 17, 2012 11:21 am
Posts: 171
Location: Ponte de Lima, Portugal
Congratulations!


Mon Oct 21, 2013 2:34 pm
Profile
LQFP112 - Up with the play
User avatar

Joined: Fri Aug 16, 2013 9:40 am
Posts: 106
Sounds really smooth, OEM like :)
I guess you could most of you data/knowledge from the MS to get the initial data dialed in correctly?


Fri Oct 25, 2013 1:34 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 45 posts ]  Go to page 1, 2, 3, 4, 5  Next

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.