View unanswered posts | View active topics It is currently Mon Dec 18, 2017 2:02 am



Reply to topic  [ 90 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7 ... 9  Next
Hentai's 1992 Mazda Miata (15th) 
Author Message
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
Fred wrote:
Hentai, this is done except for:

  • IAT and CHT, I need to know the bias resistor values on your Jaguar.
  • Scheduling pin out, I need to know if you've jumpered any FETs or not. If so, which to which CPU pins, if not, I can tell you what to do to match what I already did (same setup as previous Jaguar)
55y 2k43 = CHT, 55y 2k49 = IAT

And not doing these right now:

  • Load type for Lambda, default for now. Will split out and let you do crazy stuff soon.One of the major things I want done
  • Cam sync/sequential, this has to wait for some refactoring and new functionality, no big deal.I have a couple options, I really want to add on a proper crank trigger wheel
  • Proper characterisation of the low pulse width regions, this needs new features, later. Should be good enough for government work as is.
I figured this wouldn't be as easy as changing a load type for a 3d table

What I did:

  • Researched new data for GM 3 bar and ID1000 (full curve generated!) and added to base firmware
  • Changed decoder from 4/2 to 12-1
  • Changed injector flow from 540 to 1015 cc/min
  • Changed scheduling to be correct for crank sync decoder
  • Configured 3 bar MAP for your car
  • Added a stanza to IAT for your GM sensor
  • Configured ID1000 dead time curve for your car

Let me know when you suss out those two final points, and I'll update and provide a binary.

Fred.


Mon Apr 13, 2015 4:52 pm
Profile
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
Image


Mon Apr 13, 2015 8:40 pm
Profile
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
Bench tested ecu, came into a few issue that I had to resolve including not grounding the RPM circuit, not have 12v to the other 12v input, among other things.

so far mostly stuff has been coming along ok, I still have a clt sensor not being seen when hooked up in car, but ms2 sees it fine, so likely a wiring issue with my jaguar.

Right now getting ign set before trying to start with fuel.


Fri Apr 17, 2015 6:15 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
Image

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Fri Apr 17, 2015 6:44 am
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
screwed up jag board, sent back for repairs


Fri Apr 24, 2015 5:49 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
Gutted! Mean while, Rob's a day away from claiming 35th or so using your old original board with appropriate mods :-D

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sat Apr 25, 2015 4:52 am
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14913
Location: Home sweet home!
Congratulations on getting her purring again! And really nice to hear that your dead time stuff is working SPOT ON, too! :-)

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Fri May 08, 2015 12:22 pm
Profile WWW
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
Two closely Successful 2 hour drivers on FreeEMS for the most part.

Issues I have currently.
1) MAP reading, its all over the place, I can't tune correctly without a stable reading.
2) RPM reading, again its all over the place at a stable rpm on the tach and on the boost controller, which comes off the fuel inj wire for rpm
3) Rev Limiter, its antilag, seriously I bet I started building boost around 6500-7000 revs
4) Some issue happened trying to go into boost, sounded like a misfire, I was around .7 lambda when it happened, have a 70MB datalog with it in there but I didn't see anything odd or off. timing was at 15 degrees which should be fine. I can check plug gap which I think is at .044 but even so. MS2extra has pushed these coils at 5v with mixtures in the .6x lambda range down a quarter mile without misfire.
around 5.1 -5.2 dwell on the coil
5) Hot Restart, super lean at restart if left a lone for 20-40 minutes and come back to car, like 1.3x lambda lean, normally .94 to 1. I talked to fred but I disagree completely with using the IAT table for this. I have a theory this is being caused by fuel temp. I use afterstart enrichment to fix this on ms2extra. IAT for SD should be used for what it is needed for, changes in temp effecting fueling, which I have seen, A colder day will require more fuel than a hotter day. I don't know how right now but I plan to throw a temp gauge in the fuel rail\fuel line somehow
6) tuning software, The need for good tuning software, it doesn't need super tons features, it just needs the stuff to make one person in the car be able to tune with minmial issues
7)Decoder offset, it seems it is 360- what I had in ms2extra
I have 135 in msextra and around 225 in freeems\emstune

No boosting will be done till 1 and 2 issues are figured out

1)Now once I got it to a point where I could drive with fueling around lambda, she drove great, she starts miles better than on ms2extra, for the most part before one crank rotation that I can tell she fires up.
2)I did notice in batch fire its using two shots of fuel instead of one.
3)I also noticed that with the proper dead time\offset time\etc\etc the changes in voltage from turn stuff on and off, the fueling is rock solid. I turned on lights and blower at once and it didn't have a hint of change not even engine note changed, wideband stayed at the lambda reading. Trust me, it matters when you are trying to use 1000cc injectors on a 1.6l 4 cylinder
4) It just felt amazing to see the Jaguar board with FreeEMS firmware running the vehicle with a long drive and me sweating from the heat of south ga.

I have several things to work on still, warm ups are too rich, VE table needs checked, recheck timing to verify.
You can see how bad the map reading is, its likely a software issue. I did try filtering with a fuel filter inline but it didn't help much. I could try changing locations of where I come off the intake from. In ms2extra I have it filtered with 40 in the field for it, same location same sensor, a lot more stable than this is showing.
Image


Sat May 09, 2015 5:14 am
Profile
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
I've put a couple hundred miles on the miata now with freeems running it. Soon enough another oil change will be needed


Wed May 20, 2015 5:47 pm
Profile
LQFP144 - On Top Of The Game
User avatar

Joined: Sun Jul 18, 2010 2:35 pm
Posts: 299
Fuel density needs to go up to 755
And the stoichmetric ratio should be changed to around the 14.10 area as most pumps I filled up at are up to %10 ethanol


Sat May 23, 2015 4:47 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 90 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7 ... 9  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.