View unanswered posts | View active topics It is currently Fri May 29, 2020 4:08 am



Reply to topic  [ 21 posts ]  Go to page 1, 2, 3  Next
Ahmad's 1994 Proton Wira (44th) 
Author Message
QFP80 - Contributor

Joined: Mon Oct 08, 2018 7:12 am
Posts: 44
Its all about Covid19, I had too much time at home. Currently working on my 1994 Proton Wira, with Mitsubishi 4G61 engine convertion. Later it will 4G63T take in place.
Attachment:
IMG_20200327_200115.jpg
IMG_20200327_200115.jpg [ 791.75 KiB | Viewed 435 times ]

Attachment:
IMG_20200327_200056.jpg
IMG_20200327_200056.jpg [ 1.05 MiB | Viewed 435 times ]


Previous discussion is here: viewtopic.php?f=6&t=2865&start=30
I also done modification on Coolefi Basic Ecu as suggest.
Attachment:
IMG_20200327_202622.jpg
IMG_20200327_202622.jpg [ 1.12 MiB | Viewed 435 times ]


I finish doing wiring just now, but it is suit the one and only... MICROLEB. :lol2:
No worries about the wiring harness, I can do an adaptor to suit Coolefi. Once both ecu is ready and Covid19 going away my plan is todo dyno on Freeems vs Microtech to see which is produce more power.
Attachment:
IMG_20200327_201600.jpg
IMG_20200327_201600.jpg [ 1.67 MiB | Viewed 435 times ]


Thats all for now. Please stay safe. Stay at home. 8-)


Fri Mar 27, 2020 2:07 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15361
Location: Home sweet home!
Re the Lebo ECU vs FreeEMS (or any other ECU for that matter) max power is easy to come by, harder is economy/efficiency and/or driveability.

Funny to see LibreHacks mentioned on here - for a long time I *really* didn't want that as I felt it was fragmenting a community that was already small enough. And at the time that was a fair thought. 5 years on, though, the comedy of errors has long since ceased and the forum is even more dead than this one. RIP, Libre hacks.

Mean while, although I don't hack on the firmware often, I still do hack on the firmware, and am daily driving it in one car, and have it as the only way to drive another car that I don't use often (because not legal right now). FreeEMS is not dead, yet. The IC is not end of lifed yet. But in both cases, Lithium batteries and modern electric motors have put the writing on the wall. I'll keep burning fuel for fun until the day I die or they arrest and lock me up for breaking future emissions laws. But I can see myself in an EV for mundane driving chores at some point, too. Once something like the Rivian is affordable for me, I'll take the plunge.

Sorry for derailing your thread - you just brought back a bunch of memories and nostalgia for me.

Good luck with the build! PS, where's your first start video as evidence you're allowed to post in this still-exclusive section??? ;-)

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Thu Apr 02, 2020 10:47 am
Profile WWW
QFP80 - Contributor

Joined: Mon Oct 08, 2018 7:12 am
Posts: 44
Fred wrote:

Good luck with the build! PS, where's your first start video as evidence you're allowed to post in this still-exclusive section??? ;-)

No start yet, as I'am waiting for a pre-compile S19 for Mitsi 4/2 and working copy of Emstudio. Or just stick me a link that can guide me how to compile S19 from source code. At least I can learn something during this lockdown period.


Fri Apr 03, 2020 5:29 pm
Profile
QFP80 - Contributor

Joined: Mon Oct 08, 2018 7:12 am
Posts: 44
Fred wrote:
Re the Lebo ECU vs FreeEMS (or any other ECU for that matter) max power is easy to come by, harder is economy/efficiency and/or driveability.

Funny to see LibreHacks mentioned on here - for a long time I *really* didn't want that as I felt it was fragmenting a community that was already small enough. And at the time that was a fair thought. 5 years on, though, the comedy of errors has long since ceased and the forum is even more dead than this one. RIP, Libre hacks.

Mean while, although I don't hack on the firmware often, I still do hack on the firmware, and am daily driving it in one car, and have it as the only way to drive another car that I don't use often (because not legal right now). FreeEMS is not dead, yet. The IC is not end of lifed yet. But in both cases, Lithium batteries and modern electric motors have put the writing on the wall. I'll keep burning fuel for fun until the day I die or they arrest and lock me up for breaking future emissions laws. But I can see myself in an EV for mundane driving chores at some point, too. Once something like the Rivian is affordable for me, I'll take the plunge.

Sorry for derailing your thread - you just brought back a bunch of memories and nostalgia for me.

Good luck with the build! PS, where's your first start video as evidence you're allowed to post in this still-exclusive section??? ;-)

I'm still googling what Re The Lebo is :lol2: . Actually somewhere in 2016, I buy Cooefi Basic Ecu. Then few month later, I only know Libreems is a fork from Freeems and it point me here.

PS: Sorry for the wrong section, please move to right one.


Fri Apr 03, 2020 7:31 pm
Profile
QFP80 - Contributor

Joined: Mon Oct 08, 2018 7:12 am
Posts: 44
Today progress, I load my ecu with this : http://builds.freeems.org/firmware/mast ... nd2.s19.gz

and it seems connect with Emstudio.
Attachment:
s1.png
s1.png [ 228.54 KiB | Viewed 367 times ]

Attachment:
s2.png
s2.png [ 250.06 KiB | Viewed 367 times ]

Attachment:
s3.png
s3.png [ 122.38 KiB | Viewed 367 times ]


One issue, it not sync with my engine. Iat and clt is at reasonable value. With stimulator (4g63 trigger) also no sync. Where is my mistake?


Mon Apr 06, 2020 1:56 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15361
Location: Home sweet home!
4g63 trigger sync from what? A real CAS turning in a drill or a jimstim or what? jimstim has a bad pattern that does not match the real car/CAS, and thus doesn't work with fussy FreeEMS which *does* match. You could probably get running with that firmware if the engine parameters are the same, if not you could bodge it, but better to do something better.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Thu Apr 09, 2020 11:31 am
Profile WWW
QFP80 - Contributor

Joined: Mon Oct 08, 2018 7:12 am
Posts: 44
I do testing at engine, cranking, no sync. Take it out, and hook on ardustim, still not sync. Or probably Basic Ecu and Jaguar have a different cam/crank input?


Thu Apr 09, 2020 5:26 pm
Profile
LQFP144 - On Top Of The Game
User avatar

Joined: Thu Feb 25, 2010 3:57 am
Posts: 571
Location: Gosport, IN USA
The CoolEFI Basic ECU and the Jaguar use the same components and the same MCU pins for the crankshaft and camshaft sensor inputs. The Basic ECU is just a surface mount component version of my Jaguar ECU board.

_________________
Andy.
FreeEMS vehicle #11, 1932 Ford 5 Window Coupe with a 1996 GM 3.1L SFI V6 with DIS ignition
FreeEMS vehicle #16, 1996 Chevrolet S10 2.2L SFI I4 with DIS ignition
Owner of http://www.coolefi.com


Thu Apr 09, 2020 5:31 pm
Profile WWW
QFP80 - Contributor

Joined: Mon Oct 08, 2018 7:12 am
Posts: 44
Ok, let me try another shoot. Just load this http://builds.freeems.org/firmware/mast ... nd2.s19.gz alone or need to add other s19? I dont know how to explain, but rpm seen jumping around, Dockwidget is rapidly green,red,green,red...

What is minimum require sensor input needed? Iat I hook 1k resistor to stimulate reading. I dont have real sensor yet.


Thu Apr 09, 2020 6:30 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 15361
Location: Home sweet home!
Either you have cam/crank reversed, or polarity somehow reversed or VR/hall settings on the board wrong, or something - maybe you have bad interference from your starter motor current draw.

flashing red/green is a solid sign that it's trying to sync and failing - in the case of 4/2 it's state based and thus will do that repeatedly if the signal is wrong, never finding a sequentially matching pair of states that prove sync, and actually prove the opposite, and thus loses it.

Do you own a scope? If you own a scope, check the signals for noise, otherwise check the signals for polarity - those CAS units require a pull up - I forget the value, but guessing the default on those boards is fine as I was involved in helping Andy with the design and spec. 1k probably adequate, much lower would likely burn out the transistors in the CAS.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Fri Apr 10, 2020 3:36 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 21 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.