View unanswered posts | View active topics It is currently Sun Jun 25, 2017 11:38 pm



This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Settings That Affect Cranking Behaviour 
Author Message
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14621
Location: Home sweet home!
I thought I'd do a post on "getting it to start" and also "getting it to start nicely. Expect edits in future. Will leave an edit log at the bottom as Andy has been doing in other posts.

Before attempting to start, while checking timing, you may run into some sync losses. These can sometimes be configured away, otherwise they need wiring/circuit attention to solve. Before trying to start you should have a clean sync-loss-free cranking log under your belt. Settings that affect this are:

accelerationInputEventTimeTolerance and decelerationInputEventTimeTolerance

Which have conservative defaults of "50" that often need changing to "100" or maybe more. Note you can clearly pick this in your log if you see the value of inputEventTimeTolerance go over 1500 or under 500 accompanied by a sync loss with appropriate reason code. This feature is a bit lacking right now, as once running these should be a LOT tighter. It will get a total overhaul in future. If you see the above evidence in your log, up these values to 100, possibly more.

If you can't get rid of your sync losses, and just want to get up and running now, there is a safety feature faithfully standing in your way. Sync confirmations!

syncConfirmationsRunning and syncConfirmationsStarting

The correct/optimal settings for this with a good clean signal are 0 and 255 for starting and running respectively. On the other hand, this is sure to leave a vehicle with intermittent noise on the side of the road, so lower than 255 but set such that you're confident the decoder REALLY knows, is good. To get up and running the running one may need to be lowered so your engine can get a chance to fire. The effect of this feature is to disable outputs for a while AFTER sync is REGAINED. OLV lacks this field right now and is a priority for me to get stuck in and fix. The bit is there, but wrongly labeled. Note changing 10 to 0 results in changing 11 to 1, no confirmations while running is not a supported setting :-p

Got a clean log and ready start trying to gain your placing? Read on!

Obvious stuff:

The first column of which ever tables are in use are used for cranking right now, quite likely:

VE, Lambda, Timing

This assumes your axis values are set intelligently. Setting them intelligently looks like this:

first bin = just above maximum fully charged hot cranking RPM. Usually 150 - 300 range, often 200
second bin = lower than your lowest idle RPM, if idle is 800, you might set this in the 500 - 700 range, depending on stability
third bin = higher than your highest idle RPM, if idle is 800, you might set this in the 900 - 1100 range, depending on stability
later bins = evenly spaced to your rev limit, or spaced as appropriate for your cam/turbo/setup

If set like this, the values in the first row are used for cranking purposes. Reality of MAP is that while cranking a fully closed throttle still flows enough air to nearly fill the cylinders. IE, only a few high-kpa cells are used.

For your first time the engine is very likely cold. This shouldn't bother you much, as the default warm up curve seems to suit most engines OK. Once it's running you should monitor the engine and tune it live until it's warm, logging the parameters as you go. Once warm you can stabilise and adjust the idle area to work to your taste (Lambda matches EGO and Lambda is what you want, likely stoich). You can then review the log, and tuning change points, and associated values, to determine how the warm up curve should look for your engine. Likely only tweaks are required.

The priming pulse feature affects how much fuel is available to wet the manifold pre cranking. The behaviour of this code does not suit non-OEM setups which lose pressure quickly. OEM setups hold rail pressure indefinitely such that the prime is successful. Hacked up setups often have no pressure when the key is first switched on, and thus the prime does nothing. A second prime is sometimes required in these cases. New behaviour is on the way, eventually.

Changelog

No changes/edits.

I hope that helps a few people improve their starting, or get started at all! Good luck! :-)

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sat Jan 04, 2014 1:51 am
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14621
Location: Home sweet home!
Chat to someone with cranking sync loss issues, supplementary to the above:

[12/8/13 10:02:27 AM] Fred Cooke: OK, two things can help you:
[12/8/13 10:03:30 AM] Fred Cooke: 1) this will definitely help, but is risky if the reason for loss is genuine noise (probably not?) : find syncConfirmations in FixedConfig files and change 10 to 0 which is really 11 to 1 (a confirmation is compulsory if already running)
[12/8/13 10:04:09 AM] Fred Cooke: effect: loss of sync that is quickly recovered allows timing light flashes to restart quicker and engine to maybe fire up despite intermittent sync losses
[12/8/13 10:04:44 AM] Fred Cooke: current behaviour: loss occurs and it takes ~5 engine revolutions to fire plugs again while it makes DAMN SURE it's OK to do so.
[12/8/13 10:14:20 AM] Fred Cooke: 2) This will only help if you have a genuine problem (may well be), and is also risky, but likely necessary, firmware flaw, a fix would make this a lot nicer: find inputTimeTolerance (two of them), there will be a block of config sections with (100) in them, and a default of (50), add yours @ (100) too like the others
[12/8/13 10:14:55 AM] Fred Cooke: current behaviour: compression effects during cranking can cause fake sync loss, wider tolerance needed during cranking than running
[12/8/13 10:15:06 AM] Fred Cooke: effect: you won't lose sync anymore (maybe)
[12/8/13 10:15:23 AM] Fred Cooke: effect if sync loss is for another reason (you might lose sync late and do something dumb)

With respect to setting decoder offset angle while cranking:

[12/8/13 10:15:52 AM] Fred Cooke: additionally: you can make the cranking smoother and timing setup more accurate by removing all plugs so it can spin freely with no load on the starter

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sat Jan 04, 2014 2:22 am
Profile WWW
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14621
Location: Home sweet home!
If you're using OLV to review logs of cranking and figure out what is going on, check this out for some help: viewtopic.php?f=32&t=2371

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Jan 05, 2014 5:07 am
Profile WWW
Display posts from previous:  Sort by  
This topic is locked, you cannot edit posts or make further replies.   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.