DIYEFI.org Forum
http://forum.diyefi.org/

Packages I Install
http://forum.diyefi.org/viewtopic.php?f=45&t=2673
Page 1 of 1

Author:  Fred [ Fri May 27, 2016 9:02 am ]
Post subject:  Packages I Install

I feel like I posted this several times already, and have some docs somewhere toward an easy way to get things setup to my liking, but I can't find any of it, so new thread, to be merged, if I find the original. HDD failed in a machine, so fresh install required...

1) apt-get remove nano vim-tiny
2) apt-get install vim hexer kdiff3 gnome-terminal git make gcc g++ openjdk-8-jdk eog gimp acroread kicad kolourpaint4 youtube-dl chromium-browser libreoffice openssh-server ttf-mscorefonts-installer
3) Firefox: adblock plus
4) SSH keys, aliases, config, hosts, etc
5) ~/bin/*
6) eclipse (luna for now, mars seems broken)
7) maven3, manually, not via deb
8) freeems tools (wait, no, not possible: TODO fix this, ASAP)
9) ULV, UL, UT (vapourware, for now: TODO fix this, ASAP)

That's all, for now.

Author:  Fred [ Fri May 27, 2016 11:59 am ]
Post subject:  Re: Packages I Install

synaptics
synclient

cat /etc/X11/xorg.conf.d/50-synaptics.conf

Code:
Section "InputClass"
   Identifier "Tap Settings"
   MatchDriver "synaptics"
   Option "TapButton1" "1"
   Option "TapButton2" "2"
EndSection


cat /etc/default/grub

Code:
#GRUB_HIDDEN_TIMEOUT=0 - commented, out of date option
GRUB_TIMEOUT=2 - shortened it, 10 was too long, 30 way too long
#GRUB_CMDLINE_LINUX_DEFAULT="quiet" this must break it, or in combo with splash, splash alone is OK
GRUB_CMDLINE_LINUX_DEFAULT="splash"
#GRUB_CMDLINE_LINUX_DEFAULT="" works well, but was it quiet or splash that fucked things?
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" blue/black screen, prompt obscured
#GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" 1280x800 without i915 driver!


Bios disable of tpd_tip or some such thing.

openjdk-9-jdk packages a bit broken in 16.04

working well now, ready to rumble once again.

Author:  Fred [ Fri May 27, 2016 2:07 pm ]
Post subject:  Re: Packages I Install

I have:

  • Built EMStudio (and updated some docs)
  • Connected to a device and recorded a log
  • Viewed that log in ULV
  • Downloaded benchtest firmware from the build server
  • Loaded it using UL
  • Recorded a new superior log with ULV CLI
  • Viewed that log in ULV

And now it's time for:

  • Bed/sleep.

Author:  Fred [ Fri May 27, 2016 2:57 pm ]
Post subject:  Re: Packages I Install

And then I built a new UL and loaded the firmware again, for fun, and now bed. Zzzzz.

Author:  Fred [ Thu Oct 20, 2016 1:01 am ]
Post subject:  Re: Packages I Install

Windows:

Firefox
Chrome + postman
ublock origin on both
privacy badger on both
gimp
git
gvim
kdiff3
libreoffice
notepad++
putty
eclipse
oracle 8u111 JDK to make eclipse work.
python 2.7 - don't ask

TBC

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/