View unanswered posts | View active topics It is currently Thu Oct 19, 2017 9:08 pm



Reply to topic  [ 35 posts ]  Go to page Previous  1, 2, 3, 4  Next
My own reflow controller 
Author Message
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14823
Location: Home sweet home!
I had significant noise issues with my K type setup, too. I upped the filter on the input from K type to IC and that cured most of it. The details in my oven thread somewhere, you can find it if you care. Keep up the good work :-) Is your code around anywhere? Or is this a non-free project? Sorry if I already asked these questions and got answers long since forgotten.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Feb 15, 2015 3:16 am
Profile WWW
LQFP112 - Up with the play
User avatar

Joined: Sat Sep 29, 2012 9:16 pm
Posts: 148
Location: Rotterdam, the Netherlands
I know you care a lot about free software, and I don't have any particular reason to keep the code or hardware for this thing private since I
just cherrypicked my way around other people's projects and factory reference designs myself.
It's just that there's very little of it to show at the moment without any actual control code implemented.
I'll slap it on github once it is actually useable as an oven instead of it's current state of heat controlled lamp dimmer.

About the K-type noise: I have significant filtering in place (I think), but still no relief. I'll have a look at your thread again when I come back
from my morning row.
I'm using the reference design, with series ferrite beads on both thermocouple lines, a 10nF parallel capacitor and a fast TVS diode on both lines.
I upped the capacitor with an additional 0.1uF but it changed nothing.
Not a showstopper if I cant solve it in HW since the kalman output is fast and clean enough, but it does bother me a lot that I couldn't fix it.

_________________
FABRICA MI DIEM, PVNC!


Sun Feb 15, 2015 10:55 am
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14823
Location: Home sweet home!
I was surprised by how touchy it was, too. Not what I expected, but when you look at the voltage levels involved it's not too surprising.

Re the source, it's more out of interest in how you did XYZ and generally following the progress in a technical way. You can license it with "read only, don't use" if you like :-D

If you have trouble tracking down the info in that thread I'll have a crack at it for you.

Fred.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Feb 15, 2015 11:08 am
Profile WWW
LQFP112 - Up with the play
User avatar

Joined: Sat Sep 29, 2012 9:16 pm
Posts: 148
Location: Rotterdam, the Netherlands
I found some passages about your struggles with noisy thermocouple readings, but I cant find any schematics of your filter setup.
Judging by the sheer amount of resistors and capacitors I would hazard a guess that you added a passive low-pass filter to the
thermocouple input. I'm a bit reluctant to follow that route since passive filters always cause some attenuation of the signal level,
and as you said the voltage levels involved are in the millivolt range as it is.

Glad to know I'm not the only one with these issues though.. I first thought I might have a bad max31855, but I checked the batch number
and it is not one of the suspect ones. In case you haven't stumbled across this already, Maxim has admitted there are 2 batches that
have been trimmed incorrectly at the factory and are actually suited for J-type tc's whilst being marked as a K-type chip.

_________________
FABRICA MI DIEM, PVNC!


Sun Feb 15, 2015 2:52 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14823
Location: Home sweet home!
I forget what I was following, but it was someone else's design that I trusted and respected. And that design included the low pass filter setup on the inputs. Considering the length of wires, I think some sort of direct passive low pass is essential, really. But yes, that's what it was. :-)

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sun Feb 15, 2015 10:29 pm
Profile WWW
LQFP112 - Up with the play
User avatar

Joined: Sat Sep 29, 2012 9:16 pm
Posts: 148
Location: Rotterdam, the Netherlands
Okay, moving on with the preparations:

Today I performed a step response test to see what kind of ramp up rate the halogen oven can provide.
Sorry to say I was woefully disappointed.
I routed my 'naked' thermocouple though the lid of the oven, set it to full power and started recording temperatures.

The result can be seen below:
Image

It starts off at around a healthy 2.2 deg C/sec ramp up rate, but it quickly transitions down to about 0.11 C/sec.
At this rate it is quite useless as a reflow oven. I still have some cards to play in order to get it up to scratch:
-Line the oven with aluminum foil (much cheaper than heat reflective tape and nearly as effective). The lid is left clear.
-Remove the light diffuser that's mounted beneath the heating element.
-Plug the holes in the lid as much as possible (there's a big hole where the bimetal switch sits, which can be removed as I will be doing my own temperature control).

The former 2 are things I've seen done in fellow flavorwave-turbo reflow ovens that potentially crank the ramp up rate above and beyond what's required.
If hat fails I will be looking for a a stonger element or a different oven.

_________________
FABRICA MI DIEM, PVNC!


Thu Feb 19, 2015 10:44 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14823
Location: Home sweet home!
How much power has it got? My litle rommelbacher didn't have much, and had a similarly slow response, It was a case of Full power, off at soak temp + a bit, wait till temp falls below soak min, or time expires, full again until peak temp, off, wait a few seconds to cool slowly then open door and cool rapidly. I got a decent temp vs time profile out of it. Unsure how much my total insulation session helped, but it certainly stopped nearby things catching fire outside the oven!

Image

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Fri Feb 20, 2015 11:34 am
Profile WWW
LQFP112 - Up with the play
User avatar

Joined: Sat Sep 29, 2012 9:16 pm
Posts: 148
Location: Rotterdam, the Netherlands
The oven is rated around 1300W, which should be enough for a small reflow oven.
I'm not the first to have used an oven like this, just have a look:

Andy Brown (who inspired me to use this type of oven in the first place) had this temp response out of
the same oven (branded differently):
Image

Who then did this:
Image

And ended up with (PID control already implemented as you can see):
Image

That's around a 1.4 C/sec ramp up to soak, followed by a slightly lower than ideal 1.2 C/sec ramp up to reflow.
Still a huge improvement in the high end of 1.1 C/sec compared to my oven's performance.

There is a big chance something is falsely affecting my readings negatively though. My sample rate was WAY to high (1 sample per 400 ms),
and I noticed the temps being processed to my csv file where still climbing long after I removed the lid.
I coded my lightbulb dimmer to make the brightness proportional to temperature, and the bulb dimmed immediately
after I removed the lid, so I'm pretty sure the serial line / harddisk couldnt keep pace with the MCU. As you can see in the log
I did not even wait for the incoming temps to start dropping again as they were still rising a minute after the lid came off :).

_________________
FABRICA MI DIEM, PVNC!


Fri Feb 20, 2015 1:40 pm
Profile
LQFP112 - Up with the play
User avatar

Joined: Sat Sep 29, 2012 9:16 pm
Posts: 148
Location: Rotterdam, the Netherlands
So, on to some performance modifications.

I lined the oven with some aluminum foil from the kitchen and did a testrun:
Image

Performance has increased by a lot. Check out the new graph (do note I am using a 1hz sampling rate this time around):
Image

Looking more respectable already. Next I removed the light diffuser as well and did another run:
Image

That resulted in the following graph:
Image

I'm guessing this will do the trick for eutectic reflow profiles.
Up to the soak range of the profile performance is better than required. The soak to reflow stage ramp up rate is a little slower than I would have liked, but
I still havent exhausted all my options yet. I'm still to plug some holes and I'm considering bringing the oven volume down by putting the tray in
and covering it with foil. If the foil survives the heat I'm pretty sure this will scrape the last bit of performance from the oven.

Need to attach my thermocouple to a test pcb though. Most of the heat is radiated, which is fine, but can be misleading when the only thing being
heated during a test is an unshielded thermocouple.

_________________
FABRICA MI DIEM, PVNC!


Fri Feb 20, 2015 8:27 pm
Profile
Moderator
User avatar

Joined: Tue Jan 15, 2008 2:31 pm
Posts: 14823
Location: Home sweet home!
What a strange and weird oven! :-o I thought you were working with something more traditional :-D Good work getting it up to speed.

_________________
DIYEFI.org - where Open Source means Open Source, and Free means Freedom
FreeEMS.org - the open source engine management system
FreeEMS dev diary and its comments thread and my turbo truck!
n00bs, do NOT PM or email tech questions! Use the forum!
The ever growing list of FreeEMS success stories!


Sat Feb 21, 2015 5:36 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 35 posts ]  Go to page Previous  1, 2, 3, 4  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF. ColorizeIt.