DIYEFI.org Forum
http://forum.diyefi.org/

New wideband controller ALM compared to Innovate LM-2
http://forum.diyefi.org/viewtopic.php?f=14&t=1033
Page 1 of 9

Author:  diyhansen [ Sun Feb 06, 2011 2:09 am ]
Post subject:  New wideband controller ALM compared to Innovate LM-2

I saw this post on FSAE:
fsae.com/eve/forums/a/tpc/f/412600868/m/44220251941

This new wideband controller from ECOTRONS uses Bosch CJ125 IC to drive the LSU4.9.
It claims 150ms faster than Innovate's LM-2, which is kind of the flagship of InnovateMotorsports.

I saw a review called "wideband shootout", and there it was claimed Innovate's wideband controller had the fastest response compared to others in the list, like ZT2, PLX, etc. I am surprised to hear that the LM-2 is so slow. 150ms latency for engine controls is way too long.

I checked the website and actually saw some oscilloscope traces that showed the comparison between Ecotrons' ALM wideband controller and Innovate's LM-2.

If that is from real data, I’d like to try it out.

Author:  Fred [ Sun Feb 06, 2011 9:45 am ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

Thanks for the links! Interesting, but the profressionalism of this econtrons crowd is a bit suspect:

"LSU4.9 is supirior than LSU4.2 with regard to reliablity and life."

superior, not supirior.

"X is superior TO Y" not "X is superior THAN Y"

Hmmmm.

The graphs show the LM2 stepping its output too, my LC1 does not do that. Why does the LM2 do that in these tests?

I've got some other widebands to try out, my exhaust really needs a second bung welded into it for parallel testing purposes.

Fred.

Author:  jbelanger [ Sun Feb 06, 2011 5:54 pm ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

I think they are cheating and have put the LM2 in a 12 update per second mode instead of instantaneous.

Jean

Author:  Fred [ Mon Feb 07, 2011 1:29 am ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

Given their language use, perhaps it was an accident! :-)

EDIT: And thanks, I didn't know such a mode was available.

Author:  ecotrons [ Thu Feb 10, 2011 5:59 pm ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

There are no accidents.
LM-2 has no "instant" mode. The default is 1/12 sec mode.
Check the LM-2 manual here: http://www.innovatemotorsports.com/support.php , page 35.
I wonder why Innovate expects people to use this kind of slow signal as an ECU input.
It looks like the LC-1 has the "instant" mode. I will get a LC-1 and do the comaprison test against the ALM.
I believe the real data are better than thousands of words.
Thanks, Fred, for pointing the language errors.
Matt

Author:  jbelanger [ Thu Feb 10, 2011 6:33 pm ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

I (wrongly) based my message on the assumption that Innovate's expensive model would be able to do at least the same thing as the cheap model.

It will be interesting to see the difference when the instantaneous LC1 mode is used for comparison. I think there won't be a significant difference in delay between the ALM and Innovate but we'll have to see.

Jean

Author:  Fred [ Fri Feb 11, 2011 12:04 am ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

You're welcome! Try upping the professionalism a bit and you might get a better response :-)

I'd put my money with Jean on the LC1 coming through pretty good, though. If the sensor is really better, and I'm sure it is, and the Bosch chip is top notch (possible), then it should be faster. It would be nice to do a test with some sort of jet of precombusted gasses to instantly (or close to it) switch from lean to rich or vice versa, and measure the total delay, and therefore the percentage too.

PS, how many accounts do you have on here now? :-)

Fred.

Author:  ecotrons [ Tue Apr 26, 2011 5:54 pm ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

Somehow it has been difficult for me to login and post on this forum.
Don't know why.

Anyway, in case I can post this time, here is our result of the comparison between ALM and LC-1: ALM beats LC-1 easily in accuracy and response time, though LC-1 is faster than LM-2. LC-1 is very noisy at "instant mode", and I wonder that's why LM-2 removed the "instant mode".
For details, follow this link, we have a lot of pictures of comparison.
ecotrons.com/ALM_VS_LC-1.html

Image

Matt

Author:  jbelanger [ Tue Apr 26, 2011 6:44 pm ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

That's an interesting result. It would be good to see other controllers but I understand that it may not be practical (or economical) to do so.

One thing that I don't see for your product is the possibility of chaining multiple units on the same communication port (RS232 in your case). That makes running more than one unit a pain to configure and log. Also, I don't see any information on the serial protocol and speed you use. That would be very useful if someone wanted to use it for close loop control instead of having to deal with the DAC-ADC conversion errors (having the possibility of running a ratiometric output would be nice to minimize these errors but I'm not aware of any controller doing that).

And since you're using a microcontroller that has a CAN port, it might be the way to go to provide the digital data directly to an ECU or a datalogger. That would allow multiple units to be connected together and a high communication speed to use a fast sampling rate.

Jean

Author:  Fred [ Tue Apr 26, 2011 11:16 pm ]
Post subject:  Re: New wideband controller ALM beats Innovate LM-2

Another thing not on the chart is the source change, and distance from the engine. A fast EGT would go nicely in there for comparative purposes, also.

I used the LC1 for a long time, always in instant mode.... and never saw such noise in my setup. The LC1 uses a switching supply for the heater, and if not grounded and powered correctly, could easily be noisy. Was your wiring up to par for the device design? (ie, replying with "same wiring on both" isn't a fair excuse as that's like saying that a ferrari and a hummer require the same tyres...).

Re forum, emails have been giving trouble, but not the forum itself. If you have trouble with that, check your connection for stability and maybe consider using another browser (if you're using IE) or checking for spyware that could be using cookies to redirect things around.

Fred.

Page 1 of 9 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/