DIYEFI.org Forum
http://forum.diyefi.org/

Compiling on > qt5.6
http://forum.diyefi.org/viewtopic.php?f=12&t=2832
Page 1 of 1

Author:  AncientGeek [ Mon Oct 23, 2017 8:37 pm ]
Post subject:  Compiling on > qt5.6

trying to compile on debian stretch which has qt5.7.. there are many problems. I'm using Mike's git repo.
main problem is declarative class has been obsoleted. Found a script that renames functions and += in .pro files
It compiles bit further and then this. I don't know qt so I'm stuck.
First few errors:
In file included from src/gaugewidget.h:27:0,
from src/gaugewidget.cpp:22:
src/gaugeitem.h:86:38: error: ‘QStyleOptionGraphicsItem’ does not name a type
void paint(QPainter *painter, const QStyleOptionGraphicsItem *style , QWidget * w);
^~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/gaugewidget.cpp:23:0:
src/roundgaugeitem.h:42:41: error: ‘QStyleOptionGraphicsItem’ does not name a type
void paint(QPainter *painter, const QStyleOptionGraphicsItem *style , QWidget *w);
^~~~~~~~~~~~~~~~~~~~~~~~
In file included from src/gaugewidget.cpp:24:0:
src/bargaugeitem.h:41:41: error: ‘QStyleOptionGraphicsItem’ does not name a type
void paint(QPainter *painter, const QStyleOptionGraphicsItem *style , QWidget *w);
^~~~~~~~~~~~~~~~~~~~~~~~
src/gaugewidget.cpp: In constructor ‘GaugeWidget::GaugeWidget(QWidget*)’:
src/gaugewidget.cpp:30:62: error: no matching function for call to ‘QQuickView::QQuickView(QWidget*&)’
GaugeWidget::GaugeWidget(QWidget *parent) : QQuickView(parent)

Author:  ToxicGumbo [ Mon Oct 23, 2017 8:41 pm ]
Post subject:  Re: Compiling on > qt5.6

Which branch are you using? When he added qt5 support, he dropped FreeEMS support, so using his newer source will be an uphill battle.

Author:  Fred [ Mon Oct 23, 2017 9:41 pm ]
Post subject:  Re: Compiling on > qt5.6

AncientGeek, can you not install QT4 along side it? I seem to recall having both on various systems of mine. Let me check for you for stretch...

Yeah, they are: https://packages.debian.org/stretch/qt4-default

This should get you close:

Code:
fred@karma:~$ apt-cache show emstudioqt4-dev
Package: emstudioqt4-dev
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 0
Maintainer: Fred Cooke <:-p>
Architecture: all
Version: 1.0
Depends: git, build-essential, qt4-qmake, pkg-config, libqt4-dev, libqt4-opengl-dev, libqwt-dev, libqt4-declarative, libqjson-dev, freeglut3-dev
Description: A meta package for working with, and building, EMStudio QT4-based sources. Built from Git hash 54c495e.
Description-md5: fbf456804417ef5bc666ff87c13f2b18


So just do a sudo apt-get install git build-essential qt4-qmake pkg-config libqt4-dev libqt4-opengl-dev libqwt-dev libqt4-declarative libqjson-dev freeglut3-dev and you should be in business. Hopefully.

There's a couple of updated branches for both app and plugin (that we should combine) that I can hook you up with. These have been working well for John, RobUSA, RobR33, Steve, Jeff, Me, and others. EDIT: PM sent.

Author:  Fred [ Mon Oct 23, 2017 9:50 pm ]
Post subject:  Re: Compiling on > qt5.6

ToxicGumbo wrote:
Which branch are you using? When he added qt5 support, he dropped FreeEMS support, so using his newer source will be an uphill battle.

Also, last time I played with it it was really buggy. The branch we've worked on has only bug fixes, so it's decidedly less buggy in some really important ways.

Author:  AncientGeek [ Tue Oct 24, 2017 6:19 pm ]
Post subject:  Re: Compiling on > qt5.6

Thanks guys. I was wasting my time in so many ways. Compiled and running with a bit of extra help from Fred.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/